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1. Notes on Using the High-performance Embedded Workshop

This section shows notes on using the High-performance Embedded Workshop.

1.1 Network drive

1.1.1 Time discrepancies between computers

The time kept by a computer differs between computers. The time when a source file or output file is updated
depends on the computer on which the file has been saved.

Building of a project can be incorrect because of this difference in times kept by computers if a source file or
output file is shared via a network.

If such a problem occurs, adjust the time between all computers or use [Build -> Build All] to build a project.

1.1.2 Building a project on a network drive

When you build a project on the network an error might occur depending on the condition of the network.
For example, a C/C++ compiler might output the following error message.

C3019(F) Cannot open source file

If such an error occurs, build the project again.

1.1.3 Adding afile to a project

When you add a file on a remote drive on the network via [Project -> Add Files] or else, the High-

performance Embedded Workshop might cause an application error depending on the condition of the
network.

In this case, try to add the file to the project again. If application errors occur many times, consider copying
the file to a local drive then adding to the project.

1.2 Syntax coloring of the editor

With the syntax coloring capability of the High-performance Embedded Workshop, comments and keywords in
a source program file are colored. But the syntax coloring of the High-performance Embedded Workshop editor
does not work correctly depending on the way the source code is written.

Disable the syntax coloring if you are not satisfied with the syntax coloring. To disable it, select [Setup ->

Options], uncheck “Enable Syntax Coloring” on the [Editor] tab of the [Options] dialog box, and click on the
OK button.

Syntax coloring for C/C++ source files does not work correctly in the following cases:
(i) A comment is nested.

Example: /* /* */ */ <- The underlined part is colored as a comment.

(iD)“/*” or “*/” is contained in a string.

Example: /* <- The underlined part is colored as a comment.
char A[]=“*/"; <- The underlined part is colored as a comment.
*/

To prevent this problem, avoid writing * or / characters adjacent to each other (unless such characters are part of
a comment) in a C/C++ source file.
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1.3 File dependencies scanned

The High-performance Embedded Workshop scans an include file of a source file to show dependencies of
source files on the “Projects” tab of the “Workspace” window and to decide whether to build a file or not.

Even though the source code is syntactically correct, an error message may appear indicating that an include file
has not been correctly recognized as a dependent file.

In such cases, (a) build all files by selecting [Build -> Build All] or (b) select the source file in the “Projects” tab
of the “Workspace” window and select [Build -> Build (file name)].

Include files written in C/C++ source files are not correctly detected as dependent files in the following cases:

(i) “/*” or “*/” is contained in a string.

Example: char A[] = “/*”; <- Assumed as the beginning of a comment.
#include “file.h” <- This file is not detected as a dependent file.
char B[] = “*/”; <- Assumed as the end of a comment.

To support preprocessor statements such as #if, #ifdef, and #define by the High-performance Embedded
Workshop, go to the [Build] menu to open the toolchain option dialog box. On the “Toolchain Option” tab,
check “Support dependency scan of preprocessor statement”.

Table 1.1 shows the preprocessor statements that are currently supported.

Table 1.1

Preprocessor Statements

Preprocessor Statement Description
#define Defines an identifier. When any preprocessor statements include the identifier, this
identifier is replaced with the defined character string.
e.g. #define NICE_FILE “nice.h”
#include NICE_FILE
#undef Disables replacement of the defined identifier.
#include Informs the High-performance Embedded Workshop that the specified file is dependent

on the current source file.

#if , #else, and #endif
#elif

When #if <expression> is entered, the High-performance Embedded Workshop only
analyzes the range of source code that satisfies the expression.

When the value resulted from the expression is O: #if to #else

When the value resulted from the expression is 1: #else to #endif

defind macro

Entering defined (<identifier>) returns 1 when the identifier has already been defined.
Otherwise 0 is returned.

This macro is usually written as #if defined (MACRO).

#if def The High-performance Embedded Workshop assumes an #ifdef <identifier> statement

#ifndef as #if 1 when the identifier has already been defined. Otherwise #if 0 is assumed.
An #ifndef <identifier> statement, on the other hand, is assumed as #if 0 when the
identifier has already been defined, and otherwise #if 1.

#line Ignored

#error Ignored

#pragma Ignored

# Ignored

When a preprocessor statement has an expression, the following ten kinds of operators are currently supported
with the dependency check. The dependency search does not operate correctly if an operator other than those

listed below is used.

, >, >=, ==, 1= &&, and |].-
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When [Support dependency scan of preprocessor statement] has been selected, include files written in C/C++
source files are not correctly detected as dependent files in the following cases:

(ii) The toolchain included in either of the compiler packages listed below is in use and <expression> in a
preprocessor statement contains a conditional statement for comparing characters.

e C/C++ Compiler Package for SuperH Family V.5.1 to VV.9.03 Release 02

e C/C++ Compiler Package for H8SX, H8S, H8 Family V.3.0A to V.7.00 Release 00

e C/C++ Compiler Package for RX Family V.1.00 Release 00

e C Compiler Package for M16C Series and R8C Family V.5.30 Release 0 to V.5.45 Release 01
e C Compiler Package for M32C Series V.5.40 Release 0 to V.5.42 Release 00

e C Compiler Package for R32C/100 Series VV.1.01 Release 00 to V.1.02 Release 01

e C/C++ Compiler Package for M32R Family V.5.00 Release 00 to V.5.01 Release 01

e C Compiler Package for 740 Family V.1.00 Release 1 to V.1.01 Release 02

Example: #define A "a“

#if (A=="7) <- This leads to an error and include files
written on the subsequent lines will not
be detected as dependent files.

#include “Ffile.h” <- This file is not detected as a dependent

#endif file.

(iii) The toolchain included in either of the compiler packages listed below is in use and the operand of assembly
code for the function is an immediate value.

e C/C++ Compiler Package for SuperH Family V.5.1 to V.9.03 Release 02

e C/C++ Compiler Package for H8SX, H8S, H8 Family V.3.0A to V.7.00 Release 00

e C Compiler Package for M16C Series and R8C Family V.5.30 Release 0 to V.5.45 Release 00
e C Compiler Package for M32C Series V.5.40 Release 0 to V.5.41 Release 01

e C Compiler Package for R32C/100 Series VV.1.01 Release 00 to V.1.02 Release 00

e C/C++ Compiler Package for M32R Family V.5.00 Release 00 to V.5.01 Release 01

e C Compiler Package for 740 Family V.1.00 Release 1 to V.1.01 Release 02

Example: static void Change PSW PW_to UserMode(void)

{
MVFC PSW,R1
OR #OOlOOOOOh R1 <- This leads to an error and dependent files
: written on the subsequent lines will not
} be detected as dependent files.

(iv) The toolchain included in either of the compiler packages listed below is in use and the operand of assembly
code for the function is a constant integer with a radix.

e C/C++ Compiler Package for SuperH Family
e C/C++ Compiler Package for H8SX, H8S, H8 Family

Example: void func(void)
{
#pragma asm
AD1: .EQU H"7FFF <- This leads to an error and dependent files
: written on the subsequent lines will not
#pragma endasm be detected as dependent files.

}
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Include files written in assembly source files are not correctly detected as dependent files in the following case:
(v) A source file for the AS30, AS308, or AS100 contains directive "..FILE" or "@" for specifying an include file.

Example: <sample.a30 file>
-INCLUDE ..FILE@.inc <- This leads to an error and sample.inc
will not be detected as dependent files.

1.4 Navigation facilities

1.4.1 Navigation to the definition of C functions

The High-performance Embedded Workshop scans the definitions of C functions in a C/C++ source file and
displays tags of the definitions on the “Navigation” tab of the “Workspace” window so that double-clicking
on a tag will navigate you to the line of the definition in a corresponding file shown in the editor.

When the High-performance Embedded Workshop searches for the definitions of C functions, it ignores all
preprocessor directives. The High-performance Embedded Workshop thus may not be able to correctly
analyze the definitions of C functions.

For example, two definitions of func() might be displayed on the “Navigation” tab of the “Workspace”
window in the following code.

#define DEF 1

#ifdef DEF
void func(void)
{
}
#else
int func(int a)
{
}
1.4.2 Default setting for "C++ Classes" of the Navigation facilities

“C++ Classes” of the navigation facilities is disabled (unchecked) at default.
You can check the setting in the “Select Categories” dialog box (figure 1.1).

To open the “Select Categories” dialog box, right-click on the window of the “Navigation” tab and then
select “Select Categories”

Select Categories

Fleaze zelect the cateeories to scan for:
WS Defines

i G I |
W] Functions ance

[T+ Clazses

Figure 1.1 Select Categories Dialog Box
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1.4.3 Warning message by "C++ Classes" of the Navigation facilities
When "C++ Classes" of the navigation facilities is enabled (checked), the warning message will appear
(figure 1.2).

While this item is enabled, the navigation facilities run in the background. The CPU usage of your host
computer may be shown as nearly 100% (depending on the performance of the computer) and the reaction of
the High-performance Embedded Workshop may be slow.

High—performance Embedded Workshop

' E WARMNIMNG: Enabling thiz item mawy cause HEW to run slowly
L

Figure 1.2 Warning Message

15 Expression
(1) A function name of the C++ program cannot be specified for the expression symbol.

(2) No overloaded operator can be used as a function name.

1.6 Parallel Build

When a parallel build is executed, source-code messages (===> void ...) output in the Output window by M16C,
R8C C/C++ compiler VV.6.00 may not be accompanied by the corresponding error messages as shown below.

C:\Workspace\sample\initsct.c(31) : C2570 (E) invalid function declare
C:\Workspace\sample\fvector.c(39) : C2766 (E) parse error at near "_asm"”
===> void initsct(void)

===> asm(" .id ""¥"#FFFFFFFFFFFFFF¥'""");

1.7 Opening a file which caused an error

This is a note when you double-click on an error/warning message of the C/C++ Compiler or the Assembler on
the “Output” window and open the corresponding line of the corresponding file.

If the corresponding file window, however, has been minimized in the editor window area, the file is not opened
on double clicking on the error/warning message.

In this case, restore the file window or maximize it.
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1.8 Specifying the directory on an Option dialog box

Using the [Build] menu of the High-performance Embedded Workshop, you can launch an option dialog box on
which you can specify options to a tool such as a compiler.
Especially, when “Custom directory” is selected in the “Relative to” field on a dialog box as shown in figure 1.3,
an absolute path must be specified in the “Directory” field.

Belative to: ] 4
IDustDm directory ;I Cancel
Directory :

| Bromse.. |

Figure 1.3 Dialog Box to Specify a Directory Path

1.9 Replacing and finding character strings

19.1 Replacing 2-byte character codes
Select [Edit -> Replace] from the menu to bring up a dialog box. If you type a 2-byte character code into the
[Find what] or [Replace with] text box, select the [Regular expression] check box, and click on the [Replace]
button, you will see the code replaced with an incorrect character string.
Even the [Replace All] button cannot replace 2-byte character codes correctly.

To prevent this problem, deselect the [Regular expression] check box (disable the regular expression) before
replacing a 2-byte character code.

1.9.2 Finding 2-byte character codes
Select [Edit -> Find] from the menu to bring up a dialog box. If you type a 2-byte character code into the
[Find what] text box, select the [Regular expression] check box, and click on the [Find] button, you may
obtain an incorrect search result. The character string that has been found is highlighted in the [Source]
window. This highlighted string and strings before and after it may have been replaced with incorrect ones. If
you save the source file, these character strings will remain incorrect.

To prevent this problem, deselect the [Regular expression] check box (disable the regular expression) before
searching for a 2-byte character code.

1.10 Editor window

(1) Character sets
The [Editor] window does not support Unicode.

1.11 Tools Administration dialog box

1.11.1 Uninstallation of components and tools
For High-performance Embedded Workshop V.4.05 and later versions, the [Uninstall] button has been
removed from the [Tools Administration] dialog box.
Thus you cannot uninstall components or tools individually.
If you wish to uninstall any component or tool, uninstall the whole set of the High-performance Embedded
Workshop through the Windows® control panel.
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1.11.2 Deregistration of components and tools
After you have deregistered a component or tool from the High-performance Embedded Workshop by
clicking on the [Unregister] button in the [Tools Administration] dialog box, the component or tool will not
be registered to the High-performance Embedded Workshop even if you install a software product including
that component or tool.

To register the component or tool, use the [Register] button on the [Tools Administration] dialog box. The
[Tools Administration] dialog box must be invoked before a workspace is opened.

Select [Administration] from the [Tools] menu to open the [Tools Administration] dialog box.

1.12 Debugging facility (common to all debuggers)

1.12.1 Source-level execution
Even standard C libraries are executed by [Step In]. To return to a higher-level function, click on the [Step
Out] button.

In a “for” statement or a “while” statement, executing a single step does not move to the next line. To move
to the next line, execute two steps.

If [Step Out] is executed within an inline function, the program counter (PC) returns to the caller of the non-
inline function which called that inline function.

Example: When main() calls Func(), which calls inline InFunc()

10 int a = O;
11 mainQ)

12 {

13 Func(Q);
14 3}

15

16 void Func(Q)
17 {

18 InFunc(Q);
19 }

20

21 inline void InFuncQ
22 {

23 a++;

24 }

When [Step Out] is executed on line 23, the PC returns to line 14. That is, the result is the same as when
[Step Out] is executed within Func() (i.e. the PC does not stop at line 19).

1.12.2 Moving source file position after creating load module

When the source file is moved after the load module has been created, the [Open] dialog box, which specifies
the source file, may be displayed during debugging the created load module.
Select the corresponding source file and click on the [Open] button.

1.12.3 Editor window

After modifying the program displayed in the editor window and reloading the source files and load modules,
close the editor window then open it again; otherwise the program displayed in the window may not be
correct.
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1.12.4 Disassembly window

When [Step] or [Go] is executed while the disassembly and editor windows show data in source mode and
mixed mode, respectively, the program counter (PC) icon () may be placed at an incorrect position in the
disassembly window.

If you wish to start debugging with source mode selected in the disassembly window, be sure to select source
mode in the editor window.

1.12.5 Stack Trace window

When the stack trace window is opened after an interrupt function has been executed, display of data before
the interrupt function is incorrect.

1.12.6 Memory window
(1) Finding a value in memory

Be sure to select a range with a mouse or click on a specific location in the [Data] or [Code] column in the
[Memory] window before starting to search for a value in memory. If you just right-click on the [Memory]
window and start searching for a value, the found value will not be highlighted.

(2) Fonts

When a proportional font is selected, part of the characters in the view may be hidden. Fixed fonts are
recommended.

1.12.7 Entry point

Even when an entry point is specified by the ENTRY option of the linkage editor, the entry point address is
not set for the PC during program downloading. Set the PC before program execution.

1.12.8 Register window

In High-performance Embedded Workshop V.4.04 and later versions, values in registers are not saved in
sessions.

1.13 Debugging facility (SuperH family, H8X, H8S, H8 family, and RX family
debuggers)

1.13.1 Line assembly

Regardless of the Radix setting, the default for line assembly input is decimal.
Specify H’ or 0x as the radix for a hexadecimal input.

1.13.2 Loading of SYSROF format file

The debugging program of the SYSROF format cannot be loaded. Please make the debugging program by
the ELF/DWARF2 format.

1.13.3 Session file of Hitachi Debugging Interface
The session file of Hitachi Debugging Interface cannot be used.
Please make the file as project workspace of High-performance Embedded Workshop.
The command file of Hitachi Debugging Interface can be used.

1.13.4 Profiler
Profiler does not support overlay function.
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1.13.5 Stack Trace window
Inline functions that have been expanded as intended are not displayed in the history of function calls.

1.13.6 Reference of variables
(1) Local variables in inline functions

While the PC is pointing to an address in an inline function, you cannot use the windows or functions given
below to reference the parameters of functions or the values of local variables defined in functions.

(2) Local variables after optimization
Depending on the generated object code, the windows and functions given below do not correctly show the
values of local variables in a C source file that is compiled with the optimization option enabled.
Check the generated object code in the [Disassembly] window.

(3) Memory caching
With memory caching enabled, the windows and functions given below may not display the correct values of
variables while a program using little endian is being debugged. For example, the 4-byte variable at address
0x2002 in the following code will not be displayed correctly.

#pragma address data=0x2002
long data;

To prevent this problem, use the CACHE command to disable caching.
For notes on the CACHE command, refer to section 1.17.1, CACHE command.

cache off

e The Stack Trace window
e The Locals window

e The Watch window

e Tooltip Watch function

e Instant Watch function

1.13.7 Watch window
(1) Expanding variables
When a watch item is located outside the scope in debugging of a program, the item is automatically
collapsed if it has been expanded.
The realtime update setting on the first child item applies to the entire watch item.

(2) Automatic update of variables

When a variable has been cast and then added to the Watch window, automatic update of the variable is not
possible.
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1.13.8 Configure Overlay dialog box
This dialog box may look as if a section adjacent to an overlay section is also adjacent to another overlay
section.
If overlay sections are allocated as (1), (2), and (3) in example 1 and then re-allocated after build as in
example 2, the [Configure Overlay] dialog box will be as shown in example 3.

Example 1:

<Section>

(1 P11, P12%

) "pP21"

(3) "P31, P32"
Example 2:

<Sec> <Start - End >

"P11" 0x1000 - Ox10FF (*1)

"P12" 0x1100 - Ox12FF

"P21" 0x1000 - Ox10FF (*1)

"P31" 0x1000 - Ox105F

"P32" 0x1060 - Ox11FF

*1. The end address of "P11"™ having an adjacent section is the same

as that of "P21" having no adjacent section.

Example 3:

<Section>

(1 P11, P12"

(2) "P21, P12" (*2)

(3) "P31, P32"

*2. Looks as if "P12" is adjacent to "P21".

1.13.9 Command
(1) WATCH_EDIT command
If two or more variables with the same name are assigned different scope and are being watched in the

[Watch] window, editing the value of the variable by using the WATCH_EDIT command only changes the
value of the first variable with that name listed in the [Watch] window.

1.13.10 SuperH family and H8SX, H8S, H8 family simulators/debuggers
(1) Memory resource setting function

Note that the specifications of the memory resource setting function of the simulator/debugger differ from
those of Renesas emulators.

The specifications for the simulator/debugger are as follows:

e When the memory attribute (Read, Write, or Read/Write) is the same after the memory resource is modified:
The simulator/debugger assumes the memory resource size has been modified and changes the memory
resource size to the specified value.

e When the memory attribute changes due to modification of the memory resource:

The simulator/debugger assumes the memory resource attribute has been modified and changes the memory
resource attribute of the specified range to the specified value.

(2) The number of breakpoints and the number of Stop-at points in the Run menu
Up to a total of 1,024 PC breakpoints and Stop-at points in the Run menu can be specified.
If 1,024 breakpoints are specified, no Stop-at points in the Run menu can be specified.
Specify 1,024 or fewer points for the total numbers of PC breakpoints and Stop-at points in the Run menu.
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(3) Debug Settings dialog box

Do not perform automatic target connection

The target is connected when [Debug Settings] have been completed irrespective of the setting for the [Do

not perform automatic target connection] check box on the [Options] tab.

(4) SH-4 and SH-4 with BSC simulator/debugger

In SH-4 with BSC simulator/debugger, if the lower three bits of the source and destination addresses differ in
a DMA transfer, the last data transferred will be invalid.

e.g- SAR0=2000 DAR0O=4004 DMATCRO=2 CHCR0O=5491
Memory contents of address H"2000: 0102030405060708
Contents of address H"4004 after DMA transfer: 0106

In SH-4 and SH-4 with BSC simulator/debugger, even if an instruction is modified for an address where
decoding has been completed, the pipeline is not reset and executed.

In SH-4 with BSC simulator/debugger, if memory is accessed by a data size that differs from the size
specified by the break data, the program may not break when the break conditions are satisfied. To avoid this,
specify the same data size for the memory access data size and break data size.

In SH-4 and SH-4 with BSC simulator/debugger, the pipeline execution for double precision FDIV and
FSQRT instructions in the SH-4 simulator/debugger is different from those in the user system. For the SH-4
simulator/debugger, one more cycle is displayed for the F3 stage pipeline.

(5) SH-3DSP simulator/debugger

Exception code during DSP loop execution
If an exception is generated during the DSP loop execution, the exception code set in the EXPEVT
(exception event register) will differ from that described in the programming manual.

The exception code in the DSP Loop

General exception events Programming Simulator
Manual
TLB miss exception/TLB invalid exception (Read) H"070 H"040
TLB miss exception/TLB invalid exception (Write) H"070 H"060
TLB protection exception (Read) H"0DO H"0AO
TLB protection exception (Write) H"0DO H"0CO
CPU address error (Read) H"070 H"0EO
CPU address error (Write) H"070 H"100

X/Y memory access conflict

If an instruction code and data are allocated to the XRAM memory (or XROM, or YROM, or YRAM), stalls
will not be generated by a conflict even if this XRAM memory is accessed by the instruction code fetch and
the MOV X or MOVY instruction in the same slot. Therefore, the number of cycles for these two types of
access will differ.

Pipeline execution from an address other than a multiple of four

If a pipeline execution is performed from an address other than a multiple of four, the fetch stages will differ
from those described in the programming manual.

e.g. When pipeline execution is performed from an address other than a multiple of four
Programming Manual Simulator

IF IF ID EX IF ID EX
IF ID EX IF ID EX
it ID EX it ID EX
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(6) Trace function (only for the SH3, SH3E, and SH-3DSP)

e FPU, MAC, or DSP register access information
When an instruction is executed to write data in the FPU, MAC, or DSP register, the simulator/debugger
does not display access information in the trace information.

e Pipeline display
For instructions that programming manuals do not describe as writing back data to registers, and if data is
written to registers as a result of the execution of such instructions, the simulator/debugger displays such an
operation as a stage of memory access and write back in the trace information. The numbers of cycles are
correctly displayed.

Trace display by the simulator/debugger Description in the

programming manual
IF DE EX MA SW IF DE EX MA SW

05 NOP 06 05 06 05

06 TRAPA #H"10 07 06 05 -- 06

-— - - - - - -- -- 06 -- -- 06

-— - - - - - -- -- 06 06 -- -- 06

-— - - - - - -- -- 06 06 -- -- 06

-— - - - - - -- -— 06 06 06 (06):SSR<-60000001 -- —- 06

-— - - - - - 08 -- -- 06 06 (06):SPC<-00001006 07 -- --

-— - - - - - 09 08 -- -- - 08 07 —

(7) H8SX Simulator/debugger
H8SX Simulator/debugger does not support Middle mode of H8SX CPU.

(8) Selection of the simulator target
When you create a project, select the simulator target corresponding to the CPU and the operating mode.

(9) Internal RAM area in the SH2A-FPU simulator/debugger
Though the memory map of the SH2A-FPU simulator/debugger shows addresses OxFFF80000 to
OxFFFBFFFF as the internal RAM area, the range of OXFFFAO000 to OXFFFBFFFF are actually reserved.
For this reason, note the followings when using the SH2A-FPU simulator/debugger:

e Only use the range of OxFFF80000 to OXFFFIFFFF as the internal RAM area.

e When a stack area is to be assigned to the internal RAM area, set the initial stack-pointer value so that it will
be within the range of OxFFF80000 to OXFFFOFFFF.

(10) Saving workspaces for older versions of the High-performance Embedded Workshop
In High-performance Embedded Workshop V.4.04 and later versions, workspaces can be saved in the format
compatible with older versions of the High-performance Embedded Workshop. Note, however, that the
operation of the simulator/debugger may be extremely slow. If you intend to use this new feature, set the
trace capacity as 32,768 or less.

1.14 Windows and dialog boxes

1.141 Scrolling

(1) Up-scrolling may not be available with an intelligent mouse. In this case, use a scrolling button on the
window.

(2) If your PC has a touchpad with a scroll zone, scrolling the [Disassembly] window or the [Editor] window in
the mixed or disassembly mode while pressing the mouse or touchpad button may cause an application error.
Do not use the touchpad-scroll feature on the [Disassembly] or [Editor] window while pressing the mouse or
touchpad button.
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1.14.2 Saving the location of windows
The location of windows displayed may be changed by the following operations.

o Refresh the session after it has been saved
e Re-connect the target after it has been disconnected
e Switch the virtual desktop

1.15 Help

When the help is used in Windows® English version, the following message box may be displayed:

Click on the [Download] button to download “Japanese Text Display Support’, or check the [Never download
any of these components.] check box and click on the [Cancel] button.

Even if ‘Japanese Text Display Support’ is not downloaded, the help is normally displayed.

a Internet Explorer Install on Demand HE

To dizplav language characters comectly vou need to
download and install the following components:

Japanesze Test Dizplay Support

Download Size: 2.7 MB Dawrload Time: 23 min

r Mever download any of theze components.

Download Cancel

Figure 1.4 Internet Explorer Install on Demand message box

1.16 Macro-Recording Support facility

If you use the macro-recording facility to record the action of selecting [Debug -> Go] and [Debug -> Halt

Program] into a macro, playing this macro will carry out [Debug -> Go] only. [Debug -> Halt Program] will not
be carried out.

1.17 Commands

1.17.1 CACHE command

Do not specify the CACHE command unless it is defined in the user’s manual of the emulator or debugger.
The unit of an access to the cache memory is a fixed value such as 0x3FF. Thus the range of the cache
memory being accessed may be larger than the access range specified by the user.

1.17.2 MEMORY_EDIT command

Even if characters are enclosed with quotation marks (), the ASCII character strings cannot be input as data.
When the character strings are input as data, enter the corresponding numerical values.

1.17.3 MEMORY_FIND command
DOUBLE (double-precision floating-point number; 8 bytes) is not specifiable for parameter <mode>.
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1.17.4 Command batch file load timing (Debug Settings dialog box)
If you have specified a batch file for [Command batch file load timing] on the [Options] page, the restrictions
listed below apply. In such cases, consider the use of other means via the GUI, e.g. menu options or toolbar
buttons, instead of commands.

(1) When the [INITIALIZE] command is specified in the batch file that [At target connection] has been selected
for [Command batch file load timing] on the [Options] tab, do not execute the [INITIALIZE] command in
the [Command Line] window.

For initialization, select [Debug -> Initialize].

(2) Do not specify the following commands in the batch file that [At target connection] has been selected for
[Command batch file load timing] on the [Options] tab.

(a) [OPEN_WORKSPACE] command

(b) [CHANGE_PROJECT] command

(c) [CHANGE_CONFIGURATION] command

(3) Do not execute the [FILE_LOAD] or [FILE_LOAD_ALL] command in the [Command Line] window that
[After download of modules] has been selected for [Command batch file load timing] on the [Options] tab.

(4) Do not specify the following commands in the batch file that [Before download of modules] or [After
download of modules] has been selected for [Command batch file load timing] on the [Options] tab.

(a) [OPEN_WORKSPACE] command

(b) [CHANGE_PROJECT] command

(c) [CHANGE_CONFIGURATION] command

(d) [GO] command

(e) [GO_RESET] command

(f) [GO_TILL] command

(9) [STEP] command

(h) [STEP_OUT] command

(i) [STEP_OVER] command

(5) Do not execute the [RESET] command in the [Command Line] window that [After reset] has been selected
for [Command batch file load timing] on the [Options] tab.

(6) Do not specify the following commands in the batch file that [After reset] has been selected for [Command
batch file load timing] on the [Options] tab.

(a) [OPEN_WORKSPACE] command

(b) [CHANGE_PROJECT] command

(c) [CHANGE_CONFIGURATION] command

(d) [RESET] command

1.17.5 Command line batch processing (Debug Settings dialog box)

If you have specified the relative path to a batch file for [Command line batch processing] on the [Options]
tab, the file may not be correctly accessed.
Specify the absolute path to the batch file that cannot apply a placeholder.
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1.17.6 Specifying a file in the command line
To specify a file in the command line, use a placeholder (excluding TCL).
If you wish to specify a directory not included in the placeholder, specify an absolute path.

After specifying the absolute path, this file will not be correctly found when it is in another host computer or
environment where the path content is different. In such cases, specify the file again.

FILE_LOAD ELF/DWARF2 $(CONFIGDIR)\\demo.abs

1.17.7 Separating command parameters

You can use TCL commands while TCL is enabled. The use of the TCL command batch, in which
parameters are separated by tabs, is also possible.

For {set i 0} {$i < 2} {incr i} {
puts [memory_display 300 10]
}

When TCL is disabled, TCL commands are not usable. Only white space can be used to separate parameters
S0 using tabs instead will cause the following error.

>TCL

TCL Disabled
>memory_display 300 10
Error: Invalid command

1.17.8 Abbreviation of a command
e REMOVE_FILE

In High-performance Embedded Workshop V.3.01 or later version, the abbreviation has been changed from
“RF” to “REM”.

1.18 Enhanced compatibility between TCL commands and High-performance
Embedded Workshop commands

Due to enhanced compatibility between TCL commands and High-performance Embedded Workshop

commands*, the execution result of a High-performance Embedded Workshop command “memory_display 300
10” will not be output by the following specification.

for {set i 0} {$i < 2} {incr i} {
memory_display 300 10
}

To make the execution result of the High-performance Embedded Workshop command be output, enclose the
High-performance Embedded Workshop command with [] as a parameter of a TCL command “puts”.

for {set i 0} {$i < 2} {incr i} {
puts [memory_display 300 10]
}

*Note:  Due to this enhanced compatibility, even the execution result of a High-performance Embedded
Workshop command can be assigned to a variable as a parameter of a TCL command “set”.

In the example below, since the execution result of “memory_display 300 10” is assigned to variable
“md_300_10", you can view this result by specifying “md_300_10" with a TCL command “set”.

set md_300 10 [memory_display 300 10]
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1.19 Tcl/Tk command input

(1) Canceling the interactive mode

To return from the interactive mode to the command input mode while using the [TCL Toolkit], enter “/.”. It is
possible to know the current mode by entering “/.”.

(2) Clearing the contents of a log file
The contents of the [Console] screen are logged to a log file while using [TCL Toolkit].
The log file is in plain text format and placed in the following location:

Example 1: Windows® XP operating system

C:\Documents and Settings\<logon user name>\Local Settings\Temp\log.txt
Example 2: Windows Vista® or Windows® 7 operating system

C:\users\<logon user name>\AppData\Local\Temp\log.txt

If you quit [TCL Toolkit], it automatically erases the contents of the log file.
If you want to clear the contents of the log file while using the [TCL Toolkit], execute the following commands.

set dir $env(TEMP)
set dataFile [open $dir/log.txt {RDWR TRUNC}]
close $dataFile

1.20 Commands in TCL Toolkit and Command Line

(1) “trace” command

(a) To execute the “trace” command for Tcl in [TCL Toolkit], the command name must be specified in lowercase
letters.

(b) To execute the “TRACE” command for Hew in [TCL Toolkit], the command name must be specified in
uppercase letters.

(c) To execute the “trace” command for Tcl in the [Command Line] window, the command name must be replaced
with “tcl_trace”.

(2) “clock” command

(a) To execute the “clock” command for Tcl in [TCL Toolkit], the command name must be specified in lowercase
letters.

(b) To execute the “CLOCK” command for the emulator in [TCL Toolkit], the command name must be specified in
uppercase letters.

(c) To execute the “clock” command for Tcl in the [Command Line] window, the command name must be replaced
with “tcl_clock”.

(3) “event” command

(a) To execute the “event” command for Tk in [TCL Toolkit], the command name must be specified in lowercase
letters.

(b) To execute the “EVENT” command for the emulator in [TCL Toolkit], the command name must be specified in
uppercase letters.

Note that some emulators do not support commands “CLOCK” and “EVENT”.
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2. Supplement on toolchain

2.1 File extensions

When the High-performance Embedded Workshop executes a tool of the toolchains in a build, the High-
performance Embedded Workshop leaves a subcommand file in a configuration directory.

A subcommand file of the C/C++ Compiler or the Assembler uses a file extension shown in table 2.1 with the
same filename as the input file.

The C/C++ Library Generator or the OptLinker uses a file extension shown in table 2.1 with a project name as a

filename.

The subcommand file has an attribute of a hidden file. If you want to see a hidden file, change the properties of a
directory window so that it can display hidden files.

Table 2.1 File Extensions of Subcommand Files of the Toolchains

File extension

File group

shg SuperH RISC engine C/C++ Library Generator

shc SuperH RISC engine C/C++ Compiler

sha SuperH RISC engine Assembler

h8g H8S, H8/300 C/C++ Library Generator

h8c H8S, H8/300 C/C++ Compiler

h8a H8S, H8/300 Assembler

hik OptLinker

m16cl M16C Linker

m16ci M16C Librarian

ml6cc M16C C/C++ Compiler

ml6ca M16C Assembler

m16ct M16C mkmrtbl (M3T-MR30/4)

r8ct R8C mr8ctbl (MR8C/4)

m32cl M32C Linker

m32ci M32C Librarian

m32cc M32C C Compiler

m32ct M32C mr308tbl (M3T-MR308/4)

m32rl M32R C Compiler

m32ri M32R Librarian

m32rm M32R Load module converter

m32rc M32R C Compiler

m32ra M32R Assembler

741k 740 Linker

74lb 740 Librarian

100l R32C/100 Linker

100i R32C/100 Librarian

100c R32C/100 C Compiler

100t R32C/100 mr100tbl (M3T-MR100/4)

rxg RX C/C++ Library Generator

rxc RX C/C++ Compiler

rxa RX Assembler

ré00t RX mkritbl (RI600/4)
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3. Upgrading the toolchain

When any of the following toolchains is used in a project, you can install the latest version to upgrade the toolchain

currently in use.

e C/C++ Compiler Package for SuperH Family V.5.1 or later

e C/C++ Compiler Package for H8SX, H8S, H8 Family V.3.0A or later
e C Compiler Package for M16C Series and R8C Family V.5.20 Release 1 or later

e C Compiler Package for M32C Series V.5.20 Release 1 or later
e C Compiler Package for R32C Series V.1.01 Release 00 or later

e C/C++ Compiler Package for M32R Series V.4.20 Release 1 or later

e C Compiler Package for 740 Family V.1.01 Release 01 or later

o Assembler Package for 740 Family V.4.10 Release 02 or later

To upgrade the toolchain in use

Select [Tools -> Change Toolchain Version] to open the [Change Toolchain Version] dialog box and select a

version number from [Toolchain version].

Change Toolchain Yerzion |

Toolchain name;  Fenesas SuperH RISC engine Standard
Current wersion; 91.0.0

Cancel |
CPL Farmily: ISuperH RISC engine j
T oolchair: IHenesas SuperH RISC engine Standard j

T oolzhain wersion:

Toolzhain build phazes:

| |rtErmation,.. |

Build phaze | "Yerzion
OptLinker 9.04.00
SH Aszemnbler ooz
SH C/C++ Compiler 9.02.00
SH C/C++ Library Generator 3.00.02

Figure 3.1 Change Toochain Version Dialog Box

(1) Upgrading from the SuperH Family C/C++ Compiler Package V.5.1x or H8SX, H8S, H8 Family C/C++ Compiler

Package V.3.0x
(a) Setting the standard library configuration tool
A standard library configuration tool was added.

The High-performance Embedded Workshop checks the optional information on the IM Optlnker at upgrade.
When there is a specification to enter the standard library, an option that generates a library is set (Mode -> Build a
library file (anytime)), and when there is no specification, an option that does not generate a library is set (Mode ->

Do not add a library file).
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(b) Setting the optimizing linker
The IM Optlnker, Librarian, and Stype Converter were integrated and became OptLinker.
According to the registered states of each tool before upgrade, the optional setting of OptLinker differs after upgrade.
Table 3.1 shows the succession of the option at upgrade.

Table 3.1 Succession of Option at Upgrade
Before Upgrade After Upgrade
IM Stype IM OptLinker Librarian Stype Converter
OptLinker Librarian  Converter ~ Optinker  optional Optional optional
No. state state state state information information information
1 — — — — X X X
2 — — i X X (0]
3 — — u X X (0]
4 — O — O X O X
5 — ] ] X @) X
6 — O [ ] X X O
7 — [ — [ X O X
8 — [ [ X O X
9 — [ ] [ ] X @) X
10 ] — — O O X X
11 ] — O O X O
12 ] — | X X (6]
13 | ] — ] @) X X
14 ] O O O X O
15 ] O [ X X O
16 O | — | X O X
17 | [ ] [ ] X @) X
18 ] [ [ ] X O X
19 [ ] — — [ O X X
20 [ — | O X X
21 [ — [ ] @) X (0]
22 [ ] O — [ ] O X X
23 [ ] O [ O X X
24 [ O [ O X (0]
25 [ [ ] — [ ] @) X X
26 [ ] [ O [ ] O X X
27 [ ] [ [ [ O X O

—: Unregistered, o: Registration not checked, m: Registration checked, O: Succeeded, X: Not succeeded

(2) Upgrading from the SuperH Family C/C++ Compiler Package

(a) Automatic Build for optimizing MAP
In High-performance Embedded Workshop V.2.00 (SH Ver.7.0B/Ver.7.0.01/Ver.7.0.02), to realize optimization by
using the external symbol allocation information that has been output by the optimizing linkage editor in the C
compiler, a custom phase has been provided for rebuild.
In High-performance Embedded Workshop V.2.01 or later version, automatic rebuild is enabled when MAP
optimization is executed.
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To disable the custom phase for rebuild

Since the custom phase for rebuild is not required, open the Build Phases dialog box and remove a check for the
‘Map optimize’ phase.

Build Phases HE

Build Order | Build File Order | File Mappings |

Build phaze arder:

[w]5H C/C++ Library Generator dd
[w]5H C/C++ Compiler
SH Azsembler Maodify....
OptLinker

W} ap optimize

Bemove

tove Lp

[ B

4 I I ﬂ Irnpart..
| aF. I Cancel |

Figure 3.2 Build Phases Dialog Box

i

(3) Upgrading from the C Compiler Package for M16C Series and R8C Family V.5.x

(a) Changing the object format
The object format for M16C Series and R8C Family C/C++ Compiler Package V.6.00 Release 00 and later versions
is ELF/DWARF2.
Select [Debug -> Debug Settings] to open the [Debug Settings] dialog box and select ELF/DWARF2 for [Debug

format]. After that, click on the [Modify] button to open the [Download Module] dialog box. Select ELF/DWARF2
for [File format] and also change the file extension from .x30 to .abs.

Download Module

Offset: [o0000000 =]
File format:  [ELF/DWARF2 | Cancel |

Filenarme: |$[EEINFIGDIH]H$[F'F|EIJEETNAME].al:us Ll Browse. .. |
Access size; I vI

[T Download debug information only

I Eertarm memaniverits dinitg dewnlead

[T Download automatically an karget connection

Figure 3.3 Download Module Dialog Box
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4. Converting to an RX project

When any of the following toolchains is used in a project, you can convert the project to an RX project by installing
C/C++ Compiler Package for RX Family VV.1.01 Release 00 or later.

e C/C++ Compiler Package for SuperH Family VV.9.04 Release 00

e C/C++ Compiler Package for H8SX, H8S, H8 Family V.6.02 Release 00 to VV.6.02 Release 02

e C/C++ Compiler Package for H8SX, H8S, H8 Family V.7.00 Release 00

e C Compiler Package for M16C Series and R8C Family V.5.45 Release 00 and V.5.45 Release 01
e C/C++ Compiler Package for M16C Series and R8C Family V.6.00 Release 00

This conversion only applies to the settings given below and involves updating of the current project generator to
the RX project generator.

e Toolchain build-phase options set via [Build -> RX Standard Toolchain]
e System phases of build phases (also called toolchain build phases) set via [Build -> Build Phase]

All other settings and files registered with the project (e.g. source files) or output in the configuration folder or make
folder are not converted.

Making a backup of the current environment
It is not possible to restore projects after they have been converted.

Thus, before starting conversion, copy the workspace folder where the project has been registered (which can be
found by using the explorer) and save it with another name.

Using a debugger

If you wish to use a debugger after converting the project, add a new session in which the RX project generator is
selected.

For how to add a new session, select [Help -> Help Topic] from the main menu to open the High-performance
Embedded Workshop online help and see the topic of “Adding a session” (Debugging Facility -> Preparations for
debugging -> Debugger sessions).

Updating the contents of output files
After the project has been converted, add a session as required and take the following operations to update the
contents of the old output files.

e [Build -> Update All Dependencies]

e [Build -> Generate Makefile] *

e [Build -> Build All]

Note: *. This is necessary only when a makefile is being used.
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To convert the project to an RX project

Select [Tools -> Change Toolchain Version] to open the [Change Toolchain Version] dialog box and select “RX”
from [CPU Family].

Change Toolchain Yersion |

T oolzhain nanme:

Current wersiomn:

CPU Farnily:

SuperH RISC engine

Renezaz Superd RISC enagine Standard ok
9.4.00

Cancel

T oolchair:

IHenesas SuperH RISC engine Standard j

T oolchain wersion: IEI,#,I:I,EI

Toolchain build phazes:

~

Build phaze | Yerzion | | AfEmmatian..
OptLinker 10.00.01
SH Azzembler 701,02
SH C/C++ Compiler 9.04.00
SH C/C++ Library Generator 3.00.03

di

i

Figure 3.4 Change Toochain Version Dialog Box

The toolchain build-phase options given in the table below are inherited even after the project has been converted.
The [Skip dependency scan of nonexistent file] and [Support dependency scan of preprocessor statement] settings
(under [Toolchain Option]) are also inherited.
All other toolchain build-phase options and system phases of build phases have the default values for the RX.

(a) C/C++ Compiler Package for SuperH Family VV.9.04 Release 00 -> RX

Phase Options before Conversion Options after Conversion

Compiler C/C++ <Source> [Show  -include C/C++ <Source> [Show  -include
entries for :] [Include file entries for :] [Include file
directories] directories]
C/C++ <Source> [Show  -define C/C++ <Source> [Show  -define
entries for :] [Defines] entries for :] [Defines]
C/C++ <Source> [Show -preinclude C/C++ <Source> [Show -preinclude
entries for :] [Preinclude entries for :] [Preinclude
files] files]
C/C++ <Source> [Show -message C/C++ <Source> [Show -message

entries for :] [Messages]
[Repressed information
level messages]

entries for :] [Messages]
[Repressed information
level messages]

C/C++ <Source> [Show
entries for :] [File inline
path]

-file_inline_path

C/C++ <Source> [Show
entries for :] [File inline
path]

-file_inline_path
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Phase Options before Conversion Options after Conversion
There is no -lang C/C++ <Source> [Show -lang
corresponding GUI entries for:] [Source file]
item. The High- [Language ]
performance Embedded
Workshop recognizes
the language by the
extension of input files.
C/C++ <Object> [Output -code=asmcode C/C++ <Object> [Output  -output=src
file type :] file type :]
C/C++ <Object> [Output -preprocessor C/C++ <Object> [Output -output=prep
file type :] file type :]
C/C++ <Object> [Output -noline C/C++ <Object> [Output -noline
file type :] file type :]
C/C++ <Object> [Output C/C++ <Object> [Output
directory] directory]
C/C++ <Object> -debug C/C++ <Object> -debug
[Generate debug [Generate debug
information)] information)]
C/C++ <Object> -section C/C++ <Object> -section
[Details] [Section :] [Details] [Section :]
C/C++ <Optimize> -optimize C/C++ <Optimize> -optimize
[Optimize level :] [Optimize level :]
C/C++ <Optimize> -case C/C++ <Optimize> -case
[Details] [Miscellaneous] [Details] [Miscellaneous]
[Switch statement :] [Switch statement :]
C/C++ <Optimize> -file_inline C/C++ <Optimize> -file_inline
[Details] [Inline] [Inline [Details] [Inline] [Inline
file path] file path]
C/C++ <Optimize> -inline C/C++ <Optimize> -inline
[Details] [Inline] [Details] [Inline]
[Automatic inline [Automatic inline
expansion :] expansion :]
C/C++ <Optimize> -goptimize C/C++ <Optimize> -goptimize
[Inter-module [Inter-module
optimization] optimization]
CPU [Details] [Use try, -exception CPU [Details] [Use try, -exception
throw and catch of C++] throw and catch of C++]
CPU [Details] [Use -rtti=on CPU [Details] [Use -rtti=on
dynamic_cast and dynamic_cast and
typeid of C++] typeid of C++]
CPU [Details] [Pack -pack=1 CPU [Details] [Pack -pack
struct, union and class] struct, union and class]
CPU [Endian :] -endian CPU [Endian :] -endian

Assembler Assembly <Source> -include Assembly <Source> -include
[Show entries for:] [Show entries for:]
[Include file directories] [Include file directories]
Assembly <Source> -define Assembly <Source> -define
[Show entries for:] [Show entries for:]
[Defines] [Defines]
Assembly <Object> -debug Assembly <Object> -debug
[Generate debug [Generate debug
information) information)
Assembly <Object> Assembly <Object>
[Output directory] [Output directory]
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Phase Options before Conversion Options after Conversion

OptLinker Link/Library <Input> -library Link/Library <Input> -library
[Show entries for :] [Show entries for :]
[Library files] [Library files]
Link/Library <Input> -input Link/Library <Input> -input
[Show entries for :] [Show entries for :]
[Relocatable files and [Relocatable files and
object files] object files]
Link/Library <lnput> -binary Link/Library <Input> -binary
[Show entries for :] [Show entries for :]
[Binary files] [Binary files]
Link/Library <Input> -define Link/Library <Input> -define
[Show entries for :] [Show entries for :]
[Defines:] [Defines:]
Link/Library <Input> -entry Link/Library <Input> -entry
[Use entry point :] [Use entry point :]
Link/Library <Input> -noprelink Link/Library <Input> -noprelink
[Prelinker control :] [Prelinker control :]
Link/Library <Output> -form Link/Library <Output> -form
[Type of output file :] [Type of output file :]
Link/Library <Output> -record Link/Library <Output> -record
[Data record header :] [Data record header :]
Link/Library <Output> -byte_count Link/Library <Output> -byte_count
[Length of data record ] [Length of data record ]
Link/Library <Output> -debug Link/Library <Output> -debug
[Debug information :] [Debug information :]
Link/Library <Output> -sdebug Link/Library <Output> -sdebug
[Debug information :] [Debug information :]
Link/Library <Output> -output Link/Library <Output> -output
[Show entries for :] [Show entries for :]
[Output file path] [Output file path]
Link/Library <Output> -rom Link/Library <Output> -rom
[Show entries for :] [Show entries for :]
[ROM to RAM mapped [ROM to RAM mapped
sections:] sections:]
Link/Library <Output> -output Link/Library <Output> -output
[Show entries for :] [Show entries for :]
[Divided output files:] [Divided output files:]
Link/Library <Output> -message Link/Library <Output> -message
[Show entries for :] [Show entries for :]
[Messages] [Repressed [Messages] [Repressed
information level information level
messages:] messages:]
Link/Library <Output> -nomessage Link/Library <Output> -nomessage
[Show entries for :] [Show entries for :]
[Messages] [Repressed [Messages] [Repressed
information level information level
messages:] messages:]
Link/Library <Output> -msg_unused Link/Library <Output> -msg_unused
[Show entries for :] [Show entries for :]
[Notify unused symbol:] [Notify unused symbol:]
Link/Library <Output> -space Link/Library <Output> -space
[Specify value filled in [Specify value filled in
unused area] [Output unused area] [Output
padding data] padding data]
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Options before Conversion

Options after Conversion

Link/Library <Output> -crc Link/Library <Output> -cre
[Show entries for :] [Show entries for :]

[Generate CRC code] [Generate CRC code]

Link/Library <List> -list Link/Library <List> -list
[Generate list file] [Generate list file]

Link/Library <List> -show Link/Library <List> -show
[Contents :] [Contents :]

Link/Library <Optimize>  -optimize Link/Library <Optimize>  -optimize
[Show entries for :] [Show entries for :]

[Optimize items] [Optimize items]

[Optimize :] [Optimize :]

Link/Library <Optimize>  -nooptimize Link/Library <Optimize> -nooptimize

[Show entries for :]
[Optimize items]
[Optimize ]

[Show entries for :]
[Optimize items]
[Optimize ]

Link/Library <Optimize>
[Show entries for :]
[Forbid item]
[Elimination of dead
code]

-symbol_forbid

Link/Library <Optimize>
[Show entries for :]
[Forbid item]
[Elimination of dead
code]

-symbol_forbid

Link/Library <Optimize>
[Show entries for :]
[Forbid item]
[Elimination of same
code]

-samecode_forbid

Link/Library <Optimize>
[Show entries for :]
[Forbid item]
[Elimination of same
code]

-samecode_forbid

Link/Library <Optimize>
[Show entries for :]
[Forbid item] [Section in]

-section_forbid

Link/Library <Optimize>
[Show entries for :]
[Forbid item] [Section in]

-section_forbid

Link/Library <Optimize>
[Show entries for :]
[Forbid item] [Memory
allocation in]

-absolute_forbid

Link/Library <Optimize>
[Show entries for :]
[Forbid item] [Memory
allocation in]

-absolute_forbid

Link/Library <Section> -start Link/Library <Section> -start
[Show entries for :] [Show entries for :]

[Section] [Section]

Link/Library <Section> -fsymbol Link/Library <Section> -fsymbol
[Show entries for :] [Show entries for :]

[Symbol file] [Symbol file]

Link/Library <Verify> -cpu Link/Library <Verify> -cpu

[CPU information [CPU information

check :] check :]

Link/Library <Verify> -cpu=stride Link/Library <Verify> -cpu=stride
[CPU information [CPU information

check ] check ]

Link/Library <Verify> -contiguous_section Link/Library <Verify> -contiguous_section

[Not divide the specified
section :]

[Not divide the specified
section :]

Link/Library <Other> -stack Link/Library <Other> -stack

[Miscellaneous [Miscellaneous

options :] [Stack options :] [Stack

information output] information output]

Link/Library <Other> -total_size Link/Library <Other> -total_size

[Miscellaneous [Miscellaneous

options :] [Displays total options :] [Displays total

section size] section size]
R20UT0373EJ0100 Rev.1.00 Page 26 of 41
Feb 01, 2011 RENESAS



High-performance Embedded Workshop V.4.09

Release Note

Phase

Options before Conversion

Options after Conversion

Link/Library <Other> -s9 Link/Library <Other> -s9
[Miscellaneous [Miscellaneous

options :] [Always options :] [Always

output S9 record at the output S9 record at the

end] end]

Link/Library <Other> -memory Link/Library <Other> -memory
[Miscellaneous [Miscellaneous

options :] [Low memory options :] [Low memory

use during linkage] use during linkage]

Link/Library <Other> -compress Link/Library <Other> -compress
[Miscellaneous [Miscellaneous

options :] [Compress options :] [Compress

debug information] debug information]

Link/Library -subcommand Link/Library -subcommand

<Subcommand file>
[Use external
subcommand file]

<Subcommand file>
[Use external
subcommand file]

(b) C/C++ Compiler Package for H8SX, H8S, H8 Family V.6.02 Release 00 to V.6.02 Release 02 -> RX

Phase Options before Conversion Options after Conversion

Compiler C/C++ <Source> [Show  -include C/C++ <Source> [Show  -include
entries for :] [Include file entries for :] [Include file
directories] directories]
C/C++ <Source> [Show  -define C/C++ <Source> [Show  -define
entries for :] [Defines] entries for :] [Defines]
C/C++ <Source> [Show -preinclude C/C++ <Source> [Show  -preinclude
entries for :] [Preinclude entries for :] [Preinclude
files] files]
C/C++ <Source> [Show -message C/C++ <Source> [Show -message

entries for :] [Messages]
[Repressed information
level messages]

entries for :] [Messages]
[Repressed information
level messages]

C/C++ <Source> [Show
entries for :] [File inline

-file_inline_path

C/C++ <Source> [Show
entries for :] [File inline

-file_inline_path

path] path]

C/C++ <Object> [Output -code=asmcode C/C++ <Object> [Output -output=src

file type :] file type :]

C/C++ <Object> [Output -preprocessor C/C++ <Object> [Output -output=prep

file type :] file type :]

C/C++ <Object> [Output C/C++ <Object> [Output

directory] directory]

C/C++ <Object> -debug C/C++ <Object> -debug

[Generate debug [Generate debug

information] information]

C/C++ <Object> [Output  -outcode C/C++ <Object> [Output -outcode

character code:] character code:]

C/C++ <Object> -section C/C++ <Object> -section

[Details] [Section :] [Details] [Section :]

C/C++ <Optimize> -optimize C/C++ <Optimize> -optimize

[Optimize level :] [Optimize level :]

C/C++ <Optimize> -case C/C++ <Optimize> -case

[Details] [Miscellaneous] [Details] [Miscellaneous]

[Switch statement :] [Switch statement :]
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Phase Options before Conversion Options after Conversion
C/C++ <Optimize> -file_inline C/C++ <Optimize> -file_inline
[Details] [Inline] [Inline [Details] [Inline] [Inline
file path] file path]
C/C++ <Optimize> -goptimize C/C++ <Optimize> -goptimize
[Inter-module [Inter-module
optimization] optimization]
CPU [Details] [Use try, -exception CPU [Details] [Use try, -exception
throw and catch of C++] throw and catch of C++]
CPU [Details] [Use -rtti=on CPU [Details] [Use -rtti=on
dynamic_cast and dynamic_cast and
typeid of C++] typeid of C++]
CPU [Details] [Pack -pack=1 CPU [Details] [Pack -pack
struct, union and class] struct, union and class]

Assembler Assembly <Source> -include Assembly <Source> -include
[Show entries for:] [Show entries for:]
[Include file directories] [Include file directories]
Assembly <Source> -define Assembly <Source> -define
[Show entries for:] [Show entries for:]
[Defines] [Defines]
Assembly <Object> -debug Assembly <Object> -debug
[Generate debug [Generate debug
information) information)]
Assembly <Object> -goptimize Assembly <Object> -goptimize
[Inter-module [Inter-module
optimization] optimization]
Assembly <Object> Assembly <Object>
[Output directory] [Output directory]

OptLinker Link/Library <Input> -library Link/Library <Input> -library
[Show entries for :] [Show entries for :]
[Library files] [Library files]
Link/Library <Input> -input Link/Library <Input> -input
[Show entries for :] [Show entries for :]
[Relocatable files and [Relocatable files and
object files] object files]
Link/Library <Input> -binary Link/Library <Input> -binary
[Show entries for :] [Show entries for :]
[Binary files] [Binary files]
Link/Library <Input> -define Link/Library <Input> -define
[Show entries for :] [Show entries for :]
[Defines:] [Defines:]
Link/Library <lnput> -entry Link/Library <Input> -entry
[Use entry point :] [Use entry point :]
Link/Library <Input> -noprelink Link/Library <Input> -noprelink
[Prelinker control :] [Prelinker control :]
Link/Library <Output> -form Link/Library <Output> -form
[Type of output file :] [Type of output file :]
Link/Library <Output> -record Link/Library <Output> -record
[Data record header :] [Data record header :]
Link/Library <Output> -byte_count Link/Library <Output> -byte_count
[Length of data record :] [Length of data record :]
Link/Library <Output> -debug Link/Library <Output> -debug
[Debug information :] [Debug information :]
Link/Library <Output> -sdebug Link/Library <Output> -sdebug
[Debug information :] [Debug information :]
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Options before Conversion

Options after Conversion

Link/Library <Output> -output Link/Library <Output> -output
[Show entries for :] [Show entries for :]

[Output file path] [Output file path]

Link/Library <Output> -rom Link/Library <Output> -rom
[Show entries for :] [Show entries for :]

[ROM to RAM mapped [ROM to RAM mapped

sections:] sections:]

Link/Library <Output> -output Link/Library <Output> -output
[Show entries for :] [Show entries for :]

[Divided output files:] [Divided output files:]

Link/Library <Output> -message Link/Library <Output> -message
[Show entries for :] [Show entries for :]

[Messages] [Repressed [Messages] [Repressed

information level information level

messages:] messages:]

Link/Library <Output> -nomessage Link/Library <Output> -nomessage
[Show entries for :] [Show entries for :]

[Messages] [Repressed [Messages] [Repressed

information level information level

messages:] messages:]

Link/Library <Output> -msg_unused Link/Library <Output> -msg_unused
[Show entries for :] [Show entries for :]

[Notify unused symbol:] [Notify unused symbol:]

Link/Library <Output> -space Link/Library <Output> -space
[Specify value filled in [Specify value filled in

unused area] [Output unused area] [Output

padding data] padding data]

Link/Library <Output> -crc Link/Library <Output> -crc
[Show entries for :] [Show entries for :]

[Generate CRC code] [Generate CRC code]

Link/Library <List> -list Link/Library <List> -list
[Generate list file] [Generate list file]

Link/Library <List> -show Link/Library <List> -show
[Contents :] [Contents :]

Link/Library <Optimize>  -optimize Link/Library <Optimize> -optimize
[Show entries for :] [Show entries for :]

[Optimize items] [Optimize items]

[Optimize :] [Optimize :]

Link/Library <Optimize>  -nooptimize Link/Library <Optimize>  -nooptimize

[Show entries for :]
[Optimize items]
[Optimize :]

[Show entries for :]
[Optimize items]
[Optimize :]

Link/Library <Optimize>
[Show entries for :]
[Forbid item]
[Elimination of dead
code]

-symbol_forbid

Link/Library <Optimize>
[Show entries for :]
[Forbid item]
[Elimination of dead
code]

-symbol_forbid

Link/Library <Optimize>
[Show entries for :]
[Forbid item]
[Elimination of same
code]

-samecode_forbid

Link/Library <Optimize>
[Show entries for :]
[Forbid item]
[Elimination of same
code]

-samecode_forbid

Link/Library <Optimize>
[Show entries for :]
[Forbid item] [Section in]

-section_forbid

Link/Library <Optimize>
[Show entries for :]
[Forbid item] [Section in]

-section_forbid
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Link/Library <Optimize>
[Show entries for :]
[Forbid item] [Memory
allocation in]

-absolute_forbid

Link/Library <Optimize>
[Show entries for :]
[Forbid item] [Memory
allocation in]

-absolute_forbid

Link/Library <Section> -start Link/Library <Section> -start

[Show entries for :] [Show entries for :]

[Section] [Section]

Link/Library <Verify> -cpu Link/Library <Verify> -cpu

[CPU information [CPU information

check :] check :]

Link/Library <Verify> -cpu=stride Link/Library <Verify> -cpu=stride

[CPU information [CPU information

check :] check :]

Link/Library <Verify> -contiguous_section Link/Library <Verify> -contiguous_section

[Not divide the specified
section :]

[Not divide the specified
section :]

Link/Library <Other> -stack Link/Library <Other> -stack
[Miscellaneous [Miscellaneous
options :] [Stack options :] [Stack
information output] information output]
Link/Library <Other> -total_size Link/Library <Other> -total_size
[Miscellaneous [Miscellaneous
options :] [Displays total options :] [Displays total
section size] section size]
Link/Library <Other> -s9 Link/Library <Other> -s9
[Miscellaneous [Miscellaneous
options :] [Always options :] [Always
output S9 record at the output S9 record at the
end] end]
Link/Library <Other> -memory Link/Library <Other> -memory
[Miscellaneous [Miscellaneous
options :] [Low memory options :] [Low memory
use during linkage] use during linkage]
Link/Library <Other> -compress Link/Library <Other> -compress
[Miscellaneous [Miscellaneous
options :] [Compress options :] [Compress
debug information] debug information]
Link/Library -subcommand Link/Library -subcommand
<Subcommand file> <Subcommand file>
[Use external [Use external
subcommand file] subcommand file]

(c) C/C++ Compiler Package for H8SX, H8S, H8 Family V.7.00 Release 00 -> RX

Phase Options before Conversion Options after Conversion
Compiler C/C++ <Source> [Show -include C/C++ <Source> [Show -include

entries for :] [Include file entries for :] [Include file
directories] directories]
C/C++ <Source> [Show -define C/C++ <Source> [Show  -define
entries for :] [Defines] entries for :] [Defines]
C/C++ <Source> [Show  -preinclude C/C++ <Source> [Show -preinclude
entries for :] [Preinclude entries for :] [Preinclude
files] files]
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C/C++ <Source> [Show -message C/C++ <Source> [Show -message
entries for :] [Messages] entries for :] [Messages]
[Repressed information [Repressed information
level messages] level messages]
C/C++ <Source> [Show  -file_inline_path C/C++ <Source> [Show -file_inline_path
entries for :] [File inline entries for :] [File inline
path] path]
C/C++ <Source> -lang C/C++ <Source> [Show -lang
[Select language of C ] entries for:] [Source file]

[Language :]

C/C++ <Object> [Output -code=asmcode C/C++ <Object> [Output  -output=src
file type :] file type :]
C/C++ <Object> [Output -preprocessor C/C++ <Object> [Output -output=prep
file type :] file type :]
C/C++ <Object> [Output C/C++ <Object> [Output
directory] directory]
C/C++ <Object> -debug C/C++ <Object> -debug
[Generate debug [Generate debug
information) information)
C/C++ <Object> [Output  -outcode C/C++ <Object> [Output  -outcode
character code:] character code:]
C/C++ <Object> -section C/C++ <Object> -section
[Details] [Section :] [Details] [Section :]
C/C++ <Optimize> -optimize C/C++ <Optimize> -optimize
[Optimize level :] [Optimize level :]
C/C++ <Optimize> -case C/C++ <Optimize> -case
[Details] [Miscellaneous] [Details] [Miscellaneous]
[Switch statement :] [Switch statement :]
C/C++ <Optimize> -file_inline C/C++ <Optimize> -file_inline
[Details] [Inline] [Inline [Details] [Inline] [Inline
file path] file path]
C/C++ <Optimize> -goptimize C/C++ <Optimize> -goptimize
[Inter-module [Inter-module
optimization] optimization]
CPU [Details] [Use try, -exception CPU [Details] [Use try, -exception
throw and catch of C++] throw and catch of C++]
CPU [Details] [Use -rtti=on CPU [Details] [Use -rtti=on
dynamic_cast and dynamic_cast and
typeid of C++] typeid of C++]
CPU [Details] [Pack -pack=1 CPU [Details] [Pack -pack
struct, union and class] struct, union and class]

Assembler Assembly <Source> -include Assembly <Source> -include
[Show entries for:] [Show entries for:]
[Include file directories] [Include file directories]
Assembly <Source> -define Assembly <Source> -define
[Show entries for:] [Show entries for:]
[Defines] [Defines]
Assembly <Object> -debug Assembly <Object> -debug
[Generate debug [Generate debug
information] information)
Assembly <Object> -goptimize Assembly <Object> -goptimize
[Inter-module [Inter-module
optimization] optimization)
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Assembly <Object> Assembly <Object>
[Output directory] [Output directory]

OptLinker Link/Library <Input> -library Link/Library <Input> -library
[Show entries for :] [Show entries for :]
[Library files] [Library files]
Link/Library <lnput> -input Link/Library <Input> -input
[Show entries for :] [Show entries for :]
[Relocatable files and [Relocatable files and
object files] object files]
Link/Library <Input> -binary Link/Library <Input> -binary
[Show entries for :] [Show entries for :]
[Binary files] [Binary files]
Link/Library <Input> -define Link/Library <Input> -define
[Show entries for :] [Show entries for :]
[Defines:] [Defines:]
Link/Library <Input> -entry Link/Library <Input> -entry
[Use entry point :] [Use entry point :]
Link/Library <lnput> -noprelink Link/Library <Input> -noprelink
[Prelinker control :] [Prelinker control :]
Link/Library <Output> -form Link/Library <Output> -form
[Type of output file :] [Type of output file :]
Link/Library <Output> -record Link/Library <Output> -record
[Data record header :] [Data record header :]
Link/Library <Output> -byte_count Link/Library <Output> -byte_count
[Length of data record :] [Length of data record :]
Link/Library <Output> -debug Link/Library <Output> -debug
[Debug information :] [Debug information :]
Link/Library <Output> -sdebug Link/Library <Output> -sdebug
[Debug information :] [Debug information :]
Link/Library <Output> -output Link/Library <Output> -output
[Show entries for :] [Show entries for :]
[Output file path] [Output file path]
Link/Library <Output> -rom Link/Library <Output> -rom
[Show entries for :] [Show entries for :]
[ROM to RAM mapped [ROM to RAM mapped
sections:] sections:]
Link/Library <Output> -output Link/Library <Output> -output
[Show entries for :] [Show entries for :]
[Divided output files:] [Divided output files:]
Link/Library <Output> -message Link/Library <Output> -message
[Show entries for :] [Show entries for :]
[Messages] [Repressed [Messages] [Repressed
information level information level
messages:] messages:]
Link/Library <Output> -nomessage Link/Library <Output> -nomessage
[Show entries for :] [Show entries for :]
[Messages] [Repressed [Messages] [Repressed
information level information level
messages:] messages:]
Link/Library <Output> -msg_unused Link/Library <Output> -msg_unused
[Show entries for :] [Show entries for :]
[Notify unused symbol:] [Notify unused symbol:]
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Link/Library <Output> -space Link/Library <Output> -space
[Specify value filled in [Specify value filled in

unused area] [Output unused area] [Output

padding data] padding data]

Link/Library <Output> -crc Link/Library <Output> -crc
[Show entries for :] [Show entries for :]

[Generate CRC code] [Generate CRC code]

Link/Library <List> -list Link/Library <List> -list
[Generate list file] [Generate list file]

Link/Library <List> -show Link/Library <List> -show
[Contents :] [Contents :]

Link/Library <Optimize> -optimize Link/Library <Optimize>  -optimize
[Show entries for :] [Show entries for :]

[Optimize items] [Optimize items]

[Optimize ] [Optimize ]

Link/Library <Optimize> -nooptimize Link/Library <Optimize> -nooptimize

[Show entries for :]
[Optimize items]
[Optimize :]

[Show entries for :]
[Optimize items]
[Optimize :]

Link/Library <Optimize>
[Show entries for :]
[Forbid item]
[Elimination of dead
code]

-symbol_forbid

Link/Library <Optimize>
[Show entries for :]
[Forbid item]
[Elimination of dead
code]

-symbol_forbid

Link/Library <Optimize>
[Show entries for :]
[Forbid item]
[Elimination of same
code]

-samecode_forbid

Link/Library <Optimize>
[Show entries for :]
[Forbid item]
[Elimination of same
code]

-samecode_forbid

Link/Library <Optimize>
[Show entries for :]
[Forbid item] [Section in]

-section_forbid

Link/Library <Optimize>
[Show entries for :]
[Forbid item] [Section in]

-section_forbid

Link/Library <Optimize>
[Show entries for :]
[Forbid item] [Memory
allocation in]

-absolute_forbid

Link/Library <Optimize>
[Show entries for :]
[Forbid item] [Memory
allocation in]

-absolute_forbid

Link/Library <Section> -start Link/Library <Section> -start

[Show entries for :] [Show entries for :]

[Section] [Section]

Link/Library <Verify> -cpu Link/Library <Verify> -cpu

[CPU information [CPU information

check :] check :]

Link/Library <Verify> -cpu=stride Link/Library <Verify> -cpu=stride

[CPU information [CPU information

check ] check ]

Link/Library <Verify> -contiguous_section Link/Library <Verify> -contiguous_section

[Not divide the specified
section :]

[Not divide the specified
section :]

Link/Library <Other> -stack Link/Library <Other> -stack

[Miscellaneous [Miscellaneous

options :] [Stack options :] [Stack

information output] information output]
R20UT0373EJ0100 Rev.1.00 Page 33 of 41
Feb 01, 2011 RENESAS



High-performance Embedded Workshop V.4.09

Release Note

Phase

Options before Conversion

Options after Conversion

Link/Library <Other> -total_size Link/Library <Other> -total_size
[Miscellaneous [Miscellaneous

options :] [Displays total options :] [Displays total

section size] section size]

Link/Library <Other> -s9 Link/Library <Other> -s9
[Miscellaneous [Miscellaneous

options :] [Always options :] [Always

output S9 record at the output S9 record at the

end] end]

Link/Library <Other> -memory Link/Library <Other> -memory
[Miscellaneous [Miscellaneous

options :] [Low memory options :] [Low memory

use during linkage] use during linkage]

Link/Library <Other> -compress Link/Library <Other> -compress
[Miscellaneous [Miscellaneous

options :] [Compress options :] [Compress

debug information] debug information]

Link/Library -subcommand Link/Library -subcommand

<Subcommand file>
[Use external
subcommand file]

<Subcommand file>
[Use external
subcommand file]

(d) C Compiler Package for M16C Series and R8C Family V.5.45 Release 00 and V.5.45 Release 01 -> RX

Phase Options before Conversion Options after Conversion

Compiler C <Source> [Show -l C/C++ <Source> [Show  -include
entries for :] [Include file entries for :] [Include file
directories] directories]
C <Source> [Show -D C/C++ <Source> [Show  -define
entries for :] [Defines] entries for :] [Defines]
C <Object> [Output file -S C/C++ <Object> [Output -output=src
type ] file type :]
C <Object> [Output file ~ -P C/C++ <Object> [Output -output=prep
type ] file type :]
C <Object> [Output file -E C/C++ <Object> [Output -output=prep
type ] file type :]
C <Object> [Specifies -dir C/C++ <Object> [Output
the directory to output directory]
the file(s) to 1]
C <Object> [Debug -g C/C++ <Object> -debug
options :] [Outputs [Generate debug
debugging information. information)]
Therefore you can
perform C language-
level debugging.]

Assembler Assembly <Source> - Assembly <Source> -include
[Show entries for:] [Show entries for:]
[Include file directories] [Include file directories]
Assembly <Source> -D Assembly <Source> -define
[Show entries for:] [Show entries for:]
[Defines] [Defines]
Assembly <Object> -0 Assembly <Object> -output

[Output file directory :]

[Output directory]
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Assembly <Object> -S Assembly <Object> -debug
[Specifies file local [Generate debug
symbol information be information]
output.]
Assembly <Object> -SM Assembly <Object> -debug
[Specifies system label [Generate debug
and local symbol information]
information output.]
Optink Link <Input> [Show -L Link/Library <Input> -library
entries for :] [Library [Show entries for :]
files] [Library files]
Link <Input> [Show Link/Library <Input> -input
entries for :] [Show entries for :]
[Relocatable files] [Relocatable files and
object files]
Link <Input> [Specifies -E Link/Library <Input> -entry
start address of [Use entry point :]
absolute module ]
Link <Output> [Outputs -G Link/Library <Output> -debug
source debug [Debug information :]
information to absolute Link/Library <Other> -stack
module file.] [Miscellaneous
options :] [Stack
information output]
Link <Output> -0 Link/Library <Output> -output
[Specifies absolute [Output file path]
module file name :]
Link <Subcommand @ Link/Library -subcommand
file> [Use external <Subcommand file>
subcommand file.] [Use external
subcommand file]
Lmc <Output> -H Link/Library <Output> -form
[Format 3] [Type of output file :]
Librarian <Operation> -C Link/Library <Output> -form
[Operation :] [Type of output file :]
RTOS RTOS <Mkritbl> RTOS <Mkritbl>
[Search directory for [Search directory for
MRC files] MRC files]
(e) C/C++ Compiler Package for M16C Series and R8C Family V.6.00 Release 00 -> RX
Phase Options before Conversion Options after Conversion
Compiler C/C++ <Source> [Show -lang C/C++ <Source> [Show -lang
entries for :] [Source entries for:] [Source file]
file] [Specifies the [Language :]
language of the source
file]
C/C++ <Source> [Show -l C/C++ <Source> [Show  -include
entries for :] [Include file entries for :] [Include file
directories] directories]
C/C++ <Source> [Show -D C/C++ <Source> [Show  -define
entries for :] [Defines] entries for :] [Defines]
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Phase Options before Conversion Options after Conversion
C/C++ <Source> [Show  -preinclude C/C++ <Source> [Show -preinclude
entries for :] [Preinclude entries for :] [Preinclude
files] files]
C/C++ <Object> [Output -S C/C++ <Object> [Output -output=src
file type :] file type :]
C/C++ <Object> [Output -P C/C++ <Object> [Output  -output=prep
file type :] file type :]
C/C++ <Object> -dir C/C++ <Object> [Output
[Specifies the directory directory]
to output the file(s) to ]
C/C++ <Object> [Debug -g C/C++ <Object> -debug
options :] [Outputs [Generate debug
debugging information. information)]
Therefore you can
perform C language-
level debugging.]
C/C++ <Optimize> -goptimize C/C++ <Optimize> -goptimize
[Inter-module [Inter-module
optimization] optimization]
CPU [Use try, throw and -exception CPU [Details] [Use try, -exception
catch of C++] throw and catch of C++]
CPU [Use -rtti=on CPU [Details] [Use -rtti=on
dynamic_cast and dynamic_cast and
typeid of C++] typeid of C++]

Assembler Assembly <Source> - Assembly <Source> -include
[Show entries for:] [Show entries for:]
[Include file directories] [Include file directories]
Assembly <Source> -D Assembly <Source> -define
[Show entries for:] [Show entries for:]
[Defines] [Defines]
Assembly <Object> -S Assembly <Object> -debug
[Specifies file local [Generate debug
symbol information be information)
output.]
Assembly <Object> -SM Assembly <Object> -debug
[Specifies system label [Generate debug
and local symbol information]
information output.]
Assembly <Object> -goptimize Assembly <Object> -goptimize
[Inter-module [Inter-module
optimization] optimization]
Assembly <Object> -0 Assembly <Object>
[Output file directory :] [Output directory]

OptLinker Link/Library <lnput> -library Link/Library <Input> -library
[Show entries for :] [Show entries for :]
[Library files] [Library files]
Link/Library <Input> -input Link/Library <Input> -input
[Show entries for :] [Show entries for :]
[Relocatable files and [Relocatable files and
object files] object files]
Link/Library <Input> -binary Link/Library <Input> -binary
[Show entries for :] [Show entries for :]
[Binary files] [Binary files]
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Phase Options before Conversion Options after Conversion
Link/Library <Input> -define Link/Library <Input> -define
[Show entries for :] [Show entries for :]

[Defines:] [Defines:]

Link/Library <Input> -entry Link/Library <Input> -entry

[Use entry point :] [Use entry point :]

Link/Library <lnput> -noprelink Link/Library <Input> -noprelink

[Prelinker control :] [Prelinker control :]

Link/Library <Output> -form Link/Library <Output> -form

[Type of output file :] [Type of output file :]

Link/Library <Output> -record Link/Library <Output> -record

[Data record header :] [Data record header :]

Link/Library <Output> -byte_count Link/Library <Output> -byte_count

[Length of data record :] [Length of data record :]

Link/Library <Output> -debug Link/Library <Output> -debug

[Debug information :] [Debug information :]

Link/Library <Output> -sdebug Link/Library <Output> -sdebug

[Debug information :] [Debug information :]

Link/Library <Output> -output Link/Library <Output> -output

[Show entries for :] [Show entries for :]

[Output file path] [Output file path]

Link/Library <Output> -rom Link/Library <Output> -rom

[Show entries for :] [Show entries for :]

[ROM to RAM mapped [ROM to RAM mapped

sections:] sections:]

Link/Library <Output> -output Link/Library <Output> -output

[Show entries for :] [Show entries for :]

[Divided output files:] [Divided output files:]

Link/Library <Output> -message Link/Library <Output> -message

[Show entries for :] [Show entries for :]

[Messages] [Repressed [Messages] [Repressed

information level information level

messages:] messages:]

Link/Library <Output> -nomessage Link/Library <Output> -nomessage

[Show entries for :] [Show entries for :]

[Messages] [Repressed [Messages] [Repressed

information level information level

messages:] messages:]

Link/Library <Output> -msg_unused Link/Library <Output> -msg_unused

[Show entries for :] [Show entries for :]

[Notify unused symbol:] [Notify unused symbol:]

Link/Library <Output> -space Link/Library <Output> -space

[Specify value filled in [Specify value filled in

unused area] [Output unused area] [Output

padding data] padding data]

Link/Library <Output> -crc Link/Library <Output> -crc

[Show entries for :] [Show entries for :]

[Generate CRC code] [Generate CRC code]

Link/Library <Output> -vectn Link/Library <Output> -vectn

[Show entries for :] [Show entries for :]

[Vector] [Specific [Vector] [Specific

vector :] vector :]

Link/Library <Output> -vect Link/Library <Output> -vect

[Show entries for :] [Show entries for :]

[Vector] [Empty vector :] [Vector] [Empty vector :]
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Phase

Options before Conversion

Options after Conversion

Link/Library <List> -list Link/Library <List> -list
[Generate list file] [Generate list file]

Link/Library <List> -show Link/Library <List> -show
[Contents :] [Contents :]

Link/Library <Optimize> -optimize Link/Library <Optimize>  -optimize
[Show entries for :] [Show entries for :]

[Optimize items] [Optimize items]

[Optimize :] [Optimize :]

Link/Library <Optimize>  -nooptimize Link/Library <Optimize>  -nooptimize

[Show entries for :]
[Optimize items]
[Optimize :]

[Show entries for :]
[Optimize items]
[Optimize :]

Link/Library <Optimize>
[Show entries for :]
[Forbid item]
[Elimination of dead
code]

-symbol_forbid

Link/Library <Optimize>
[Show entries for :]
[Forbid item]
[Elimination of dead
code]

-symbol_forbid

Link/Library <Optimize>
[Show entries for :]
[Forbid item] [Section in]

-section_forbid

Link/Library <Optimize>
[Show entries for :]
[Forbid item] [Section in]

-section_forbid

Link/Library <Optimize>
[Show entries for :]
[Forbid item] [Memory
allocation in]

-absolute_forbid

Link/Library <Optimize>
[Show entries for :]
[Forbid item] [Memory
allocation in]

-absolute_forbid

Link/Library <Section> -start Link/Library <Section> -start

[Show entries for :] [Show entries for :]

[Section] [Section]

Link/Library <Verify> -cpu Link/Library <Verify> -cpu

[CPU information [CPU information

check ] check ]

Link/Library <Verify> -cpu=stride Link/Library <Verify> -cpu=stride

[CPU information [CPU information

check :] check :]

Link/Library <Verify> -contiguous_section Link/Library <Verify> -contiguous_section

[Not divide the specified
section :]

[Not divide the specified
section :]

Link/Library <Other> -stack Link/Library <Other> -stack

[Miscellaneous [Miscellaneous

options :] [Stack options :] [Stack

information output] information output]

Link/Library <Other> -total_size Link/Library <Other> -total_size

[Miscellaneous [Miscellaneous

options :] [Displays total options :] [Displays total

section size] section size]

Link/Library <Other> -s9 Link/Library <Other> -s9

[Miscellaneous [Miscellaneous

options :] [Always options :] [Always

output S9 record at the output S9 record at the

end] end]

Link/Library <Other> -memory Link/Library <Other> -memory

[Miscellaneous [Miscellaneous

options :] [Low memory options :] [Low memory

use during linkage] use during linkage]
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Phase Options before Conversion Options after Conversion
Link/Library <Other> -compress Link/Library <Other> -compress
[Miscellaneous [Miscellaneous
options :] [Compress options :] [Compress
debug information] debug information]
Link/Library -subcommand Link/Library -subcommand
<Subcommand file> <Subcommand file>
[Use external [Use external
subcommand file] subcommand file]
RTOS RTOS <Mkritbl> RTOS <Mkritbl>

[Search directory for
MRC files]

[Search directory for
MRC files]

R20UT0373EJ0100 Rev.1.00

Feb 01, 2011

RENESAS

Page 39 of 41



High-performance Embedded Workshop V.4.09 Release Note

5. Compatibility with Microsoft® Windows® Vista and Windows® 7

51 With running High-performance Embedded Workshop V.4.05.00 or later on
Windows Vista® or Windows® 7 by user rights

Please take note of the following problem in using High-performance Embedded Workshop V.4.05.00 or later:
With running High-performance Embedded Workshop V.4.05.00 or later on Windows Vista® or Windows® 7
by user rights

51.1 Description
Even if your High-performance Embedded Workshop and all the software-development tools managed by it
are compatible with Windows Vista® or Windows® 7, the OS may requests you to be logged on as a
member of the Administrators group; that is, you cannot run them on the OS by user rights.
This problem arises when you are logged on as a member of the Administrators group and make the settings
for running High-performance Embedded Workshop V.4.04.01 or earlier on Windows Vista® or Windows®
7 by using the Compatibility tab, and afterward you update the IDE to the one compatible with Windows
Vista® (High-performance Embedded Workshop V.4.05.00 or later) or Windows® 7 (High-performance
Embedded Workshop V.4.08.00 or later).

NOTICE:

High-performance Embedded Workshop can run on Windows Vista® or Windows® 7 by user rights when
both of the following conditions are satisfied:

(1) The IDE is compatible with Windows Vista® (i.e. V.4.05.00 or later) or Windows® 7 (i.e. V.4.08.00 or
later).

(2) All the software-development tools managed by the IDE are also compatible with Windows Vista® or
Windows® 7.

Otherwise, you must be logged on as a member of the Administrators group to run the IDE on Windows
Vista® or Windows® 7 as well as installing any software-development tool.

5.1.2 Workarounds
To avoid the problem, use either of the following ways:
Re-setting items in the Compatibility tab of the program's Properties dialog box
a. Right-click the shortcut of High-performance Embedded Workshop to open the Properties dialog box.
b. In the Compatibility tab, clear the following two check boxes:
- Run This Program in Compatibility Mode
- Run the Program as an Administration

All trademarks and registered trademarks are the property of their respective owners.
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Notice

1. All information included in this document is current as of the date this document is issued. Such information, however, is subject to change without any prior notice. Before purchasing or using any Renesas
Electronics products listed herein, please confirm the latest product information with a Renesas Electronics sales office. Also, please pay regular and careful attention to additional and different information to
be disclosed by Renesas Electronics such as that disclosed through our website.

2. Renesas Electronics does not assume any liability for infringement of patents, copyrights, or other intellectual property rights of third parties by or arising from the use of Renesas Electronics products or
technical information described in this document. No license, express, implied or otherwise, is granted hereby under any patents, copyrights or other intellectual property rights of Renesas Electronics or
others.

3. You should not alter, modify, copy, or otherwise misappropriate any Renesas Electronics product, whether in whole or in part.

4. Descriptions of circuits, software and other related information in this document are provided only to illustrate the ion of i ictor products and icati You are fully responsible for

the incorporation of these circuits, software, and information in the design of your equipment. Renesas Electronics assumes no responsibility for any losses incurred by you or third parties arising from the
use of these circuits, software, or information.

5. When exporting the products or technology described in this document, you should comply with the applicable export control laws and regulations and follow the procedures required by such laws and
regulations. You should not use Renesas Electronics products or the technology described in this document for any purpose relating to military applications or use by the military, including but not limited to
the development of weapons of mass destruction. Renesas Electronics products and technology may not be used for or incorporated into any products or systems whose manufacture, use, or sale is
prohibited under any applicable domestic or foreign laws or regulations.

6. Renesas Electronics has used reasonable care in preparing the information included in this document, but Renesas Electronics does not warrant that such information is error free. Renesas Electronics
assumes no liability whatsoever for any damages incurred by you resulting from errors in or omissions from the information included herein.

7. Renesas Electronics products are classified according to the following three quality grades: "Standard", "High Quality", and "Specific". The recommended applications for each Renesas Electronics product
depends on the product's quality grade, as indicated below. You must check the quality grade of each Renesas Electronics product before using it in a particular application. You may not use any Renesas
Electronics product for any application categorized as "Specific” without the prior written consent of Renesas Electronics. Further, you may not use any Renesas Electronics product for any application for
which it is not intended without the prior written consent of Renesas Electronics. Renesas Electronics shall not be in any way liable for any damages or losses incurred by you or third parties arising from the
use of any Renesas Electronics product for an application categorized as "Specific" or for which the product is not intended where you have failed to obtain the prior written consent of Renesas Electronics.
The quality grade of each Renesas Electronics product is "Standard" unless otherwise expressly specified in a Renesas Electronics data sheets or data books, etc.

"Standard": Computers; office equipment; communications equipment; test and measurement equipment; audio and visual equipment; home electronic appliances; machine tools;
personal electronic equipment; and industrial robots.
"High Quality": Transportation equipment (automobiles, trains, ships, etc.); traffic control systems; anti-disaster systems; anti-crime systems; safety equipment; and medical equipment not specifically

designed for life support.

"Specific": Aircraft; equipment; i P ; nuclear reactor control systems; medical equipment or systems for life support (e.qg. artificial life support devices or systems), surgical
implantations, or healthcare intervention (e.g. excision, etc.), and any other applications or purposes that pose a direct threat to human life.

8. You should use the Renesas Electronics products described in this document within the range specified by Renesas Electronics, especially with respect to the maximum rating, operating supply voltage
range, movement power voltage range, heat radiation characteristics, installation and other product characteristics. Renesas Electronics shall have no liability for malfunctions or damages arising out of the
use of Renesas Electronics products beyond such specified ranges.

9. Although Renesas Electronics endeavors to improve the quality and reliability of its products, semiconductor products have specific characteristics such as the occurrence of failure at a certain rate and
malfunctions under certain use conditions. Further, Renesas Electronics products are not subject to radiation resistance design. Please be sure to implement safety measures to guard them against the
possibility of physical injury, and injury or damage caused by fire in the event of the failure of a Renesas Electronics product, such as safety design for hardware and software including but not limited to
redundancy, fire control and malfunction prevention, appropriate treatment for aging degradation or any other appropriate measures. Because the evaluation of microcomputer software alone is very difficult,
please evaluate the safety of the final products or system manufactured by you.

10. Please contact a Renesas Electronics sales office for details as to environmental matters such as the environmental compatibility of each Renesas Electronics product. Please use Renesas Electronics
products in compliance with all applicable laws and regulations that regulate the inclusion or use of controlled substances, including without limitation, the EU RoHS Directive. Renesas Electronics assumes
no liability for damages or losses occurring as a result of your noncompliance with applicable laws and regulations.

11. This document may not be reproduced or duplicated, in any form, in whole or in part, without prior written consent of Renesas Electronics.

12. Please contact a Renesas Electronics sales office if you have any questions regarding the information contained in this document or Renesas Electronics products, or if you have any other inquiries.

(Note 1) "Renesas Electronics" as used in this document means Renesas Electronics Corporation and also includes its majority-owned subsidiaries.

(Note 2)  "Renesas Electronics product(s)" means any product developed or manufactured by or for Renesas Electronics.
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